summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--boot/barebox/barebox.mk10
2 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7e7e25f75..f74a6acb8 100644
--- a/Makefile
+++ b/Makefile
@@ -660,6 +660,10 @@ endif
ifeq ($(BR2_TOOLCHAIN_CTNG),y)
@echo ' ctng-menuconfig - Run crosstool-NG menuconfig'
endif
+ifeq ($(BR2_TARGET_BAREBOX),y)
+ @echo ' barebox-menuconfig - Run barebox menuconfig'
+ @echo ' barebox-savedefconfig - Run barebox savedefconfig'
+endif
@echo
@echo 'Miscellaneous:'
@echo ' source - download all sources needed for offline-build'
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 5c615f862..d3143e69a 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -60,4 +60,14 @@ ifeq ($(BAREBOX_BOARD_DEFCONFIG),)
$(error No Barebox defconfig file. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG setting)
endif
endif
+
+barebox-menuconfig barebox-xconfig barebox-gconfig barebox-nconfig: barebox-configure
+ $(MAKE) $(BAREBOX_MAKE_FLAGS) -C $(BAREBOX_DIR) \
+ $(subst barebox-,,$@)
+ rm -f $(BAREBOX_DIR)/.stamp_{built,target_installed,images_installed}
+
+barebox-savedefconfig: barebox-configure
+ $(MAKE) $(BAREBOX_MAKE_FLAGS) -C $(BAREBOX_DIR) \
+ $(subst barebox-,,$@)
+
endif