summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--package/lighttpd/Config.in7
-rw-r--r--package/lighttpd/lighttpd.mk7
3 files changed, 15 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 9957d58bd..74ec64fac 100644
--- a/CHANGES
+++ b/CHANGES
@@ -69,6 +69,7 @@
#4171: makedevs-unused-but-set-variable.patch
#4183: Codesourcery toolchain download site has changed
#4231: libneon.so: undefined reference to `SSL_SESSION_cmp'
+ #4381: Add option to lighttpd to enable Lua support
2011.08, Released August 31th, 2011:
diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
index a822d9021..cb759ff46 100644
--- a/package/lighttpd/Config.in
+++ b/package/lighttpd/Config.in
@@ -44,4 +44,11 @@ config BR2_PACKAGE_LIGHTTPD_WEBDAV
help
Enable webdav support. Needed to support mod_webdav
+config BR2_PACKAGE_LIGHTTPD_LUA
+ bool "lua support"
+ depends on BR2_PACKAGE_LIGHTTPD
+ select BR2_PACKAGE_LUA
+ help
+ Enable Lua support. Needed to support mod_magnet
+
endif
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 10aa4c8e4..3f11be33b 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -49,6 +49,13 @@ else
LIGHTTPD_CONF_OPT += --without-webdav-props --without-webdav-locks
endif
+ifeq ($(BR2_PACKAGE_LIGHTTPD_LUA),y)
+LIGHTTPD_DEPENDENCIES += lua
+LIGHTTPD_CONF_OPT += --with-lua
+else
+LIGHTTPD_CONF_OPT += --without-lua
+endif
+
define LIGHTTPD_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/lighttpd
rm -f $(TARGET_DIR)/usr/sbin/lighttpd-angel