summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/games/prboom/prboom.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/games/prboom/prboom.mk b/package/games/prboom/prboom.mk
index a8c7f6548..3a50fd502 100644
--- a/package/games/prboom/prboom.mk
+++ b/package/games/prboom/prboom.mk
@@ -19,6 +19,16 @@ PRBOOM_CONF_OPT = \
--disable-sdltest \
--disable-gl
+# endianness detection isn't used when cross compiling
+define PRBOOM_BIG_ENDIAN_FIXUP
+ $(SED) 's,.*#undef WORDS_BIGENDIAN.*,#define WORDS_BIGENDIAN 1,g' \
+ $(PRBOOM_DIR)/config.h
+endef
+
+ifeq ($(BR2_ENDIAN),"BIG")
+PRBOOM_POST_CONFIGURE_HOOKS += PRBOOM_BIG_ENDIAN_FIXUP
+endif
+
define PRBOOM_INSTALL_TARGET_CMDS
$(INSTALL) -D $(@D)/src/prboom $(TARGET_DIR)/usr/games/prboom
$(INSTALL) -D $(@D)/src/prboom-game-server $(TARGET_DIR)/usr/games/prboom-game-server