summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.package.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 07511442c..66be0a237 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -487,15 +487,15 @@ $(1)-install-host: $(1)-build $$($(2)_TARGET_INSTALL_HOST)
$(1)-build: $(1)-configure \
$$($(2)_TARGET_BUILD)
-$(1)-configure: $(1)-patch \
+$(1)-configure: $(1)-patch $(1)-depends \
$$($(2)_TARGET_CONFIGURE)
$(1)-patch: $(1)-extract $$($(2)_TARGET_PATCH)
-$(1)-extract: $(1)-depends \
+$(1)-extract: $(1)-source \
$$($(2)_TARGET_EXTRACT)
-$(1)-depends: $(1)-source $$($(2)_DEPENDENCIES)
+$(1)-depends: $$($(2)_DEPENDENCIES)
$(1)-show-depends:
@echo $$($(2)_DEPENDENCIES)