summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/coreutils/coreutils.mk6
-rw-r--r--package/util-linux/util-linux.mk7
2 files changed, 13 insertions, 0 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index caad648a8..df07a0885 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -73,7 +73,13 @@ $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+#If both coreutils and busybox are selected, make certain coreutils
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+coreutils: uclibc busybox $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+else
coreutils: uclibc $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+endif
coreutils-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index fd0b7240f..8cdce9690 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -60,7 +60,14 @@ $(UTIL-LINUX_TARGET_BINARY): $(UTIL-LINUX_BINARY)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/share/info \
$(TARGET_DIR)/usr/share/man $(TARGET_DIR)/usr/share/doc
+#If both util-linux and busybox are selected, make certain util-linux
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+util-linux: uclibc busybox $(UTIL-LINUX_TARGET_BINARY)
+else
util-linux: uclibc $(UTIL-LINUX_TARGET_BINARY)
+endif
+
util-linux-source: $(DL_DIR)/$(UTIL-LINUX_SOURCE)