summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES20
-rw-r--r--package/multimedia/alsa-lib/alsa-lib.mk4
-rw-r--r--package/neon/neon.mk1
3 files changed, 14 insertions, 11 deletions
diff --git a/CHANGES b/CHANGES
index e6fbe356e..99900ad9c 100644
--- a/CHANGES
+++ b/CHANGES
@@ -14,16 +14,16 @@
New packages: cgilua, copas, coxpcall, ffmpeg, libsvgtiny,
luafilesystem, luasocket, rings, wsapi, xavante, xterm
- Updated/fixed packages: berkeleydb, bash, blackbox, busybox,
- bzip2, cdrkit, cmake, dash, dhcp, dialog, diffutils, distcc,
- dmalloc, dnsmasq, dropbear, e2fsprogs, fbv, file, fontconfig,
- gawk, gstreamer, gzip, intltool, ipsec-tools, iptables,
- libart, libcgi, libfuse, libgpg-error, libidn, liblockfile,
- libpng, links, linux-fusion, lmbench, lrzsz, make,
- module-init-tools, mysql_client, nbd, ncurses, netperf,
- ntfsprogs, openssl, php, qt, quagga, sqlite, sdl, sdl_mixer,
- sdl_sound, sdl_ttf, squashfs, tn5250, tremor, usbutils,
- xkeyboard-config, xserver_xorg-server, xvkbd
+ Updated/fixed packages: alsa-lib, berkeleydb, bash, blackbox,
+ busybox, bzip2, cdrkit, cmake, dash, dhcp, dialog, diffutils,
+ distcc, dmalloc, dnsmasq, dropbear, e2fsprogs, fbv, file,
+ fontconfig, gawk, gstreamer, gzip, intltool, ipsec-tools,
+ iptables, libart, libcgi, libfuse, libgpg-error, libidn,
+ liblockfile, libpng, links, linux-fusion, lmbench, lrzsz,
+ make, module-init-tools, mysql_client, nbd, ncurses, neon,
+ netperf, ntfsprogs, openssl, php, qt, quagga, sqlite, sdl,
+ sdl_mixer, sdl_sound, sdl_ttf, squashfs, tn5250, tremor,
+ usbutils, xkeyboard-config, xserver_xorg-server, xvkbd
Removed packages: modutils, portage, rxvt
diff --git a/package/multimedia/alsa-lib/alsa-lib.mk b/package/multimedia/alsa-lib/alsa-lib.mk
index 1f120c6f7..6e4c5754f 100644
--- a/package/multimedia/alsa-lib/alsa-lib.mk
+++ b/package/multimedia/alsa-lib/alsa-lib.mk
@@ -54,7 +54,9 @@ ALSA_LIB_CFLAGS+=-DAVR32_INLINE_BUG
endif
ifeq ($(BR2_PACKAGE_ALSA_LIB_PYTHON),y)
-ALSA_LIB_CONF_OPT += --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR)
+ALSA_LIB_CONF_OPT += \
+ --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR) \
+ --with-pythonincludes=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
ALSA_LIB_CFLAGS+=-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
ALSA_LIB_DEPENDENCIES = libpython
else
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index ed5f99968..e942f8763 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -14,6 +14,7 @@ NEON_DEPENDENCIES:=host-pkg-config
ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
NEON_CONF_OPT+=--with-libxml2=yes
NEON_CONF_OPT+=--with-expat=no
+NEON_CONF_ENV+=ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
NEON_DEPENDENCIES+=libxml2
endif
ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)