summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES3
-rw-r--r--boot/u-boot/Config.in6
-rw-r--r--boot/u-boot/u-boot.mk11
3 files changed, 14 insertions, 6 deletions
diff --git a/CHANGES b/CHANGES
index 2d8253c37..3222e7a0a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,7 +6,8 @@
and non-sysroot support removed.
Bootloaders: Various cleanups, moved to boot/, added Barebox,
- removed yaboot. Support building u-boot from custom tarball.
+ removed yaboot. Support building u-boot from custom tarball,
+ u-boot 2010.06.
New GTK-based configurator, usable using 'make gconfig'.
diff --git a/boot/u-boot/Config.in b/boot/u-boot/Config.in
index aa680cf3d..d445145eb 100644
--- a/boot/u-boot/Config.in
+++ b/boot/u-boot/Config.in
@@ -12,10 +12,13 @@ config BR2_TARGET_UBOOT_BOARDNAME
choice
prompt "U-Boot Version"
- default BR2_TARGET_UBOOT_2010_03
+ default BR2_TARGET_UBOOT_2010_06
help
Select the specific U-Boot version you want to use
+config BR2_TARGET_UBOOT_2010_06
+ bool "2010.06"
+
config BR2_TARGET_UBOOT_2010_03
bool "2010.03"
@@ -39,6 +42,7 @@ endif
config BR2_TARGET_UBOOT_VERSION
string
+ default "2010.06" if BR2_TARGET_UBOOT_2010_06
default "2010.03" if BR2_TARGET_UBOOT_2010_03
default "2009.11" if BR2_TARGET_UBOOT_2009_11
default "2009.08" if BR2_TARGET_UBOOT_2009_08
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index ad67343a9..37ed21557 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -32,9 +32,12 @@ U_BOOT_BIN:=u-boot.bin
MKIMAGE:=$(HOST_DIR)/usr/bin/mkimage
U_BOOT_TARGETS:=$(BINARIES_DIR)/$(U_BOOT_BIN) $(MKIMAGE)
+U_BOOT_ARCH=$(KERNEL_ARCH)
-# u-boot still uses arch=ppc for powerpc
+# u-boot in the past used arch=ppc for powerpc
+ifneq ($(findstring x200,$(UBOOT_VERSION))$(findstring x2010.03,$(UBOOT_VERSION)),)
U_BOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
+endif
U_BOOT_INC_CONF_FILE:=$(U_BOOT_DIR)/include/config.h
@@ -147,9 +150,9 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
$(U_BOOT_DIR)/common/image.c \
$(wildcard $(addprefix $(U_BOOT_DIR)/tools/,default_image.c \
fit_image.c imximage.c kwbimage.c mkimage.c)) \
- $(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
+ $(addprefix $(U_BOOT_DIR)/lib*/,crc32.c md5.c sha1.c) \
$(U_BOOT_DIR)/tools/os_support.c \
- $(U_BOOT_DIR)/libfdt/fdt*.c
+ $(wildcard $(U_BOOT_DIR)/libfdt/fdt*.c $(U_BOOT_DIR)/lib/libfdt/fdt*.c)
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
@@ -158,7 +161,7 @@ $(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/.configured
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
-DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib_generic/crc32.c
+ $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib*/crc32.c
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv