summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in14
-rw-r--r--package/Makefile.in4
2 files changed, 17 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 6d702a5a8..8b15d11f3 100644
--- a/Config.in
+++ b/Config.in
@@ -74,6 +74,20 @@ config BR2_WGET
string
default "wget --passive-ftp -nd"
+config BR2_STAGING_DIR
+ string "Toolchain and header file location?"
+ default "$(BUILD_DIR)/staging_dir"
+ help
+ This is the location where the toolchain will be installed.
+ Since the toolchain will not work if it is moved from this
+ location, it is important for people wishing to package up
+ a uClibc toolchain that this be set to the location in which
+ the toolchain will be used.
+
+ Most people will leave this set to the default value of
+ "$(BUILD_DIR)/staging_dir".
+
+
config BR2_TAR_VERBOSITY
bool
default n
diff --git a/package/Makefile.in b/package/Makefile.in
index 75173f763..db523d21a 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -15,8 +15,10 @@ DL_DIR:=$(BASE_DIR)/dl
#PATCH_DIR=$(BASE_DIR)/sources/patches
BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
TARGET_DIR:=$(BUILD_DIR)/root
-STAGING_DIR=$(BUILD_DIR)/staging_dir
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
+# Strip off the annoying quoting
+STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
+#"
TARGET_PATH=$(STAGING_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
IMAGE:=$(BASE_DIR)/root_fs_$(ARCH)$(ARCH_FPU_SUFFIX)
REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux-uclibc