summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--package/ncurses/ncurses.mk15
2 files changed, 18 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 2b64c337b..1682a552e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -7,11 +7,12 @@
(broken).
Updated/fixed packages: barebox, directfb, libsoup,
- libxml-parser-perl, mtd, python, ti-utils, udev, usbmount,
- util-linux, xfont_font-misc-misc
+ libxml-parser-perl, mtd, ncurses, python, ti-utils, udev,
+ usbmount, util-linux, xfont_font-misc-misc
Issues resolved (http://bugs.uclibc.org):
+ #3685: ncurses installation hangs due to old version of tic
#4093: Grub fails to install bz2 patch after conversion to...
2011.08-rc1, Released August 4th, 2011:
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index ae3f3fb70..0d425280b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -26,6 +26,7 @@
NCURSES_VERSION = 5.7
NCURSES_SITE = $(BR2_GNU_MIRROR)/ncurses
NCURSES_INSTALL_STAGING = YES
+NCURSES_DEPENDENCIES = host-ncurses
NCURSES_CONF_OPT = \
--with-shared \
@@ -120,4 +121,18 @@ define NCURSES_INSTALL_TARGET_CMDS
$(NCURSES_INSTALL_TARGET_DEVFILES)
endef # NCURSES_INSTALL_TARGET_CMDS
+#
+# On systems with an older version of tic, the installation of ncurses hangs
+# forever. To resolve the problem, build a static version of tic on host
+# ourselves, and use that during installation.
+#
+define HOST_NCURSES_BUILD_CMDS
+ $(MAKE1) -C $(@D) sources
+ $(MAKE) -C $(@D)/progs tic
+endef
+
+HOST_NCURSES_CONF_OPT = \
+ --without-shared
+
$(eval $(call AUTOTARGETS,package,ncurses))
+$(eval $(call AUTOTARGETS,package,ncurses,host))