summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--package/ctorrent/ctorrent.mk8
2 files changed, 8 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index a0e39f7ec..917572424 100644
--- a/CHANGES
+++ b/CHANGES
@@ -3,6 +3,7 @@
Issues resolved (http://bugs.uclibc.org):
#529: util-linux doesn't find headers and include libs correctly
+ #557: Build ctorrent with SSL support if available
2009.08-rc3, Released August 26th, 2009:
diff --git a/package/ctorrent/ctorrent.mk b/package/ctorrent/ctorrent.mk
index 256088180..aa2215315 100644
--- a/package/ctorrent/ctorrent.mk
+++ b/package/ctorrent/ctorrent.mk
@@ -6,6 +6,12 @@
CTORRENT_VERSION:=dnh3.3.2
CTORRENT_SOURCE:=ctorrent-$(CTORRENT_VERSION).tar.gz
CTORRENT_SITE:=http://www.rahul.net/dholmes/ctorrent/
-CTORRENT_CONF_OPT:=--with-ssl=no
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+CTORRENT_CONF_OPT+=--with-ssl=yes
+CTORRENT_DEPENDENCIES+=openssl
+else
+CTORRENT_CONF_OPT+=--with-ssl=no
+endif
$(eval $(call AUTOTARGETS,package,ctorrent))