summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--package/php/php.mk1
2 files changed, 4 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 7c424596c..f26f67f17 100644
--- a/CHANGES
+++ b/CHANGES
@@ -7,8 +7,8 @@
New packages: cgilua, copas, coxpcall, luafilesystem,
luasocket, rings, wsapi, xavante
- Updated/fixed packages: cdrkit, libidn, netperf, qt, tn5250,
- usbutils
+ Updated/fixed packages: cdrkit, libidn, netperf, php, qt,
+ tn5250, usbutils
Removed packages: modutils
@@ -20,6 +20,7 @@
#1897: Bump libusb to 1.0.7
#1903: Bump tn5250 to 0.17.4 and migrate to autotargets
#1909: netperf-2.4.5 fails to build because of undeclared SOCK_DCCP
+ #1945: PHP: add sqlite3 dependency when using external lib
2010.05, Released May 30th, 2010:
diff --git a/package/php/php.mk b/package/php/php.mk
index c5f9c140e..962547f6f 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -151,6 +151,7 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO),y)
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_SQLITE),y)
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_SQLITE_EXTERNAL),y)
PHP_CONF_OPT += --with-pdo-sqlite=$(STAGING_DIR)/usr
+ PHP_DEPENDENCIES += sqlite
else
PHP_CONF_OPT += --with-pdo-sqlite
endif