summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in8
-rw-r--r--project/Makefile.in2
2 files changed, 10 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 1881f8253..146bb17a8 100644
--- a/Config.in
+++ b/Config.in
@@ -27,6 +27,14 @@ config BR2_SVN_UP
string "Subversion (svn) command to update source tree"
default "svn up"
+config BR2_BZR_CO
+ string "Bazaar (bzr) command to download source tree"
+ default "bzr co"
+
+config BR2_BZR_UP
+ string "Bazaar (bzr) command to update source tree"
+ default "bzr up"
+
config BR2_GIT
string "Git command to download source tree"
default "git clone"
diff --git a/project/Makefile.in b/project/Makefile.in
index 7f359bcf7..69c8572e0 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -13,6 +13,8 @@ endif
WGET:=$(call qstrip,$(BR2_WGET)) $(SPIDER) $(QUIET)
SVN_CO:=$(call qstrip,$(BR2_SVN_CO)) $(QUIET)
SVN_UP:=$(call qstrip,$(BR2_SVN_UP)) $(QUIET)
+BZR_CO:=$(call qstrip,$(BR2_BZR_CO)) $(QUIET)
+BZR_UP:=$(call qstrip,$(BR2_BZR_UP)) $(QUIET)
GIT:=$(call qstrip,$(BR2_GIT)) $(QUIET)
ZCAT:=$(call qstrip,$(BR2_ZCAT))
BZCAT:=$(call qstrip,$(BR2_BZCAT))