summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile8
-rw-r--r--package/Makefile.in2
2 files changed, 3 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index a4d09eb89..53a647111 100644
--- a/Makefile
+++ b/Makefile
@@ -252,12 +252,8 @@ $(TARGET_DIR)/etc/hostname: $(TARGET_DIR) .config
source: $(TARGETS_SOURCE) $(HOST_SOURCE)
-.config.check: dependencies
- $(SED) '/BR2_WGET/s/\"$$/ --spider\"/g' .config
- touch $@
-
-_source-check: .config.check
- $(MAKE) source
+_source-check:
+ $(MAKE) SPIDER=--spider source
#############################################################
#
diff --git a/package/Makefile.in b/package/Makefile.in
index 29c505835..78731e24f 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -12,7 +12,7 @@ MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
#"))
-WGET:=$(strip $(subst ",, $(BR2_WGET)))
+WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER)
#"))
SVN:=$(strip $(subst ",, $(BR2_SVN)))
#"))