summaryrefslogtreecommitdiffstats
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index cf2ac7d23..09c30958c 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -131,6 +131,9 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
$(call MESSAGE,"Downloading")
+ifdef BR2_PRIMARY_SITE
+ -$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $(BR2_PRIMARY_SITE)/$($(PKG)_SOURCE)
+endif
$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
$(if $($(PKG)_PATCH),$(Q)test -e $(DL_DIR)/$($(PKG)_PATCH) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
$(Q)mkdir -p $(@D)