summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in9
-rw-r--r--package/Makefile.autotools.in3
2 files changed, 12 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 42682ec29..799709324 100644
--- a/Config.in
+++ b/Config.in
@@ -15,6 +15,15 @@ source "target/device/Config.in"
menu "Build options"
+config BR2_PRIMARY_SITE
+ string "Primary download site"
+ default ""
+ help
+ Primary site to download from. If this option is set then buildroot
+ will try to download package source first from this site and try the
+ default if the file is not found.
+ NOTE: This only works for packages using the Makefile.autotools.in
+
config BR2_WGET
string "Wget command"
default "wget --passive-ftp -nd"
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index cf2ac7d23..09c30958c 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -131,6 +131,9 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
$(call MESSAGE,"Downloading")
+ifdef BR2_PRIMARY_SITE
+ -$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $(BR2_PRIMARY_SITE)/$($(PKG)_SOURCE)
+endif
$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
$(if $($(PKG)_PATCH),$(Q)test -e $(DL_DIR)/$($(PKG)_PATCH) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
$(Q)mkdir -p $(@D)