summaryrefslogtreecommitdiffstats
path: root/target/u-boot/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'target/u-boot/Makefile.in')
-rw-r--r--target/u-boot/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 69877378e..5f4cd4c20 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -169,6 +169,7 @@ $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
(cd $(BINARIES_DIR); ln -s $(U_BOOT_TARGET_BIN) $(U_BOOT_BIN))
$(U_BOOT_TOOLS): $(U_BOOT_DIR)/$(U_BOOT_BIN)
+ mkdir -p $(@D)
cp -dpf $(U_BOOT_DIR)/tools/$(U_BOOT_TOOLS_BIN) $(STAGING_DIR)/usr/bin/
$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)