summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--target/u-boot/Makefile.in1
2 files changed, 2 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index fb880f5f9..b2f21dabe 100644
--- a/CHANGES
+++ b/CHANGES
@@ -16,6 +16,7 @@
#749: Bump usbutils package to version 0.86
#751: Kernel 2.6 snapshot fetch fail
#753: Bump lighttpd package to 1.4.25
+ #757: U-Boot: mkimage cannot be installed using external toolchain
#761: Add binutils 2.20 to toolchain options
#763: [SECURITY] Update pcre to 7.9
#765: Add buildroot branding to gcc
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 69877378e..5f4cd4c20 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -169,6 +169,7 @@ $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
(cd $(BINARIES_DIR); ln -s $(U_BOOT_TARGET_BIN) $(U_BOOT_BIN))
$(U_BOOT_TOOLS): $(U_BOOT_DIR)/$(U_BOOT_BIN)
+ mkdir -p $(@D)
cp -dpf $(U_BOOT_DIR)/tools/$(U_BOOT_TOOLS_BIN) $(STAGING_DIR)/usr/bin/
$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)