summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2019-05-14 14:14:48 +0200
committerSimon Rettberg2019-05-14 14:14:48 +0200
commit6cbc590a92a52a905b149608f63f459f0d785c1d (patch)
tree33305f0ecb19b90d1741e189339df3f20ab49f9d /CMakeLists.txt
parentEnforce minimum delay for RPC actions if user is active (diff)
downloadidle-daemon-6cbc590a92a52a905b149608f63f459f0d785c1d.tar.gz
idle-daemon-6cbc590a92a52a905b149608f63f459f0d785c1d.tar.xz
idle-daemon-6cbc590a92a52a905b149608f63f459f0d785c1d.zip
f() -> f(void)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 854e50a..a044dca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ project(idle-daemon C)
option(CMAKE_BUILD_TYPE Release)
set(CMAKE_C_FLAGS "-D_GNU_SOURCE")
-set(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wextra -pedantic -Werror -Wno-multichar")
+set(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wextra -pedantic -Werror -Wno-multichar -Wstrict-prototypes -Wmissing-prototypes -Wno-overlength-strings")
set(CMAKE_C_FLAGS_RELEASE "-O2 -Wno-multichar")
file(GLOB_RECURSE IDLEDAEMON_SOURCES src/*.c)