summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 854e50a..a044dca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ project(idle-daemon C)
option(CMAKE_BUILD_TYPE Release)
set(CMAKE_C_FLAGS "-D_GNU_SOURCE")
-set(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wextra -pedantic -Werror -Wno-multichar")
+set(CMAKE_C_FLAGS_DEBUG "-O0 -g -Wall -Wextra -pedantic -Werror -Wno-multichar -Wstrict-prototypes -Wmissing-prototypes -Wno-overlength-strings")
set(CMAKE_C_FLAGS_RELEASE "-O2 -Wno-multichar")
file(GLOB_RECURSE IDLEDAEMON_SOURCES src/*.c)