summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlf Gaida2018-10-14 17:54:20 +0200
committerAlf Gaida2018-11-18 19:55:53 +0100
commitdef155a5ba0b92fa04b04cc52197c0d345c87bf0 (patch)
treef80f9c7e5408f687f124881031f45b344925c90b /CMakeLists.txt
parentBump minor version to 14 (diff)
downloadpavucontrol-slx-def155a5ba0b92fa04b04cc52197c0d345c87bf0.tar.gz
pavucontrol-slx-def155a5ba0b92fa04b04cc52197c0d345c87bf0.tar.xz
pavucontrol-slx-def155a5ba0b92fa04b04cc52197c0d345c87bf0.zip
Set cmake_minimum_required(VERSION 3.1.0 FATAL_ERROR)
Removed set CMAKE_BUILD_TYPE
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9425157..139a653 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,9 @@
-cmake_minimum_required(VERSION 3.0.2 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.1.0 FATAL_ERROR)
+# CMP0000: Call the cmake_minimum_required() command at the beginning of the top-level
+# CMakeLists.txt file even before calling the project() command.
+# The cmake_minimum_required(VERSION) command implicitly invokes the cmake_policy(VERSION)
+# command to specify that the current project code is written for the given range of CMake
+# versions.
project(pavucontrol-qt)
option(UPDATE_TRANSLATIONS "Update source translation translations/*.ts files" OFF)
@@ -19,10 +24,6 @@ find_package(Qt5DBus REQUIRED)
find_package(lxqt-build-tools ${LXQTBT_MINIMUM_VERSION} REQUIRED)
-if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE Release)
-endif()
-
set(PAVUCONTROLQT_MAJOR_VERSION 0)
set(PAVUCONTROLQT_MINOR_VERSION 14)
set(PAVUCONTROLQT_PATCH_VERSION 0)
@@ -45,4 +46,3 @@ pkg_check_modules(
)
add_subdirectory(src)
-