summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2021-03-15 08:33:04 +0100
committerManuel Bentele2021-03-15 08:33:04 +0100
commitdcf4cd421bc0f93d602da9c45357be036b7b8354 (patch)
tree92e2b3d93570f2cca07404a46b946dbbaf0a6740 /CMakeLists.txt
parentAdd build support for Github actions (diff)
downloadxloop-dcf4cd421bc0f93d602da9c45357be036b7b8354.tar.gz
xloop-dcf4cd421bc0f93d602da9c45357be036b7b8354.tar.xz
xloop-dcf4cd421bc0f93d602da9c45357be036b7b8354.zip
Add support in CMake to validate (lint) the source code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce84d9a..e09e954 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,7 @@ endif(NOT CMAKE_BUILD_TYPE)
# include project version and build type related macros
include(Version)
include(Build)
+include(Lint)
# search for required packages
find_package(Git REQUIRED)