summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2017-06-26 15:58:37 +0200
committerKarel Zak2017-06-26 15:58:37 +0200
commit47ccf06b4728130beb19b05a5c13a87e2807ad3e (patch)
treeca6073f0053d6e362b623d2817edcdb3ae45d93d /Makefile.am
parentscript: rename fixtty() to enable_rawmode_tty() (diff)
parentmisc: cosmetics, remove argument from usage(FILE*) (diff)
downloadkernel-qcow2-util-linux-47ccf06b4728130beb19b05a5c13a87e2807ad3e.tar.gz
kernel-qcow2-util-linux-47ccf06b4728130beb19b05a5c13a87e2807ad3e.tar.xz
kernel-qcow2-util-linux-47ccf06b4728130beb19b05a5c13a87e2807ad3e.zip
Merge branch 'usage-part2' of https://github.com/rudimeier/util-linux
* 'usage-part2' of https://github.com/rudimeier/util-linux: misc: cosmetics, remove argument from usage(FILE*) misc: cosmetics, remove argument from usage(int) misc: never use usage(stderr) misc: never use usage(ERROR) misc: cleanup and fix --unknownopt issues flock, getopt: write --help to stdout and return 0 tools: add checkusage.sh
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 28a9d04e8..325d1f4fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -183,11 +183,15 @@ checkdecl:
checkcompletion:
@ $(top_srcdir)/tools/checkcompletion.sh $(top_srcdir)
+checkusage:
+ @ $(top_srcdir)/tools/checkusage.sh \
+ $(bin_PROGRAMS) $(sbin_PROGRAMS) \
+ $(usrbin_exec_PROGRAMS) $(usrsbin_exec_PROGRAMS)
+
DISTCHECK_CONFIGURE_FLAGS = \
--disable-use-tty-group \
--disable-silent-rules \
--enable-all-programs \
- --disable-makeinstall-chown \
--enable-static-programs \
--enable-gtk-doc \
--with-python \