summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2007-01-04 11:57:07 +0100
committerKarel Zak2007-01-04 11:57:07 +0100
commit562218e6ea1926723045713e52449c24c6ccff1f (patch)
tree2a3e34852c8f79cb1d8eae42cfda6a2abd72d0f3 /Makefile.am
parentbuild-sys: remove generated autotools stuff from git (diff)
downloadkernel-qcow2-util-linux-562218e6ea1926723045713e52449c24c6ccff1f.tar.gz
kernel-qcow2-util-linux-562218e6ea1926723045713e52449c24c6ccff1f.tar.xz
kernel-qcow2-util-linux-562218e6ea1926723045713e52449c24c6ccff1f.zip
build-sys: add missing files
This patch add all missing headers, man pages and README files to automake stuff and "make dist-gzip" produces useful tarball now. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5c3564e96..5f69f4488 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,9 @@ SUBDIRS = lib \
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = config/include-Makefile.am \
- autogen.sh
+ autogen.sh \
+ licenses/COPYING.GPL \
+ licenses/COPYING.UCB
distclean-local:
-find . \( -name \*~ -o -name \*.orig -o -name \*.rej \) -exec rm -f {} \;
@@ -31,3 +33,11 @@ mrproper: distclean
cd po; rm -f `cat .gitignore`; cd ..
cd config; rm -f `cat ../.gitignore`; cd ..
+# The automake is very stupid for work with man pages. The files from man_MANS are
+# not included to the distribution. A solution is use dist_man_MANS or
+# EXTRA_DIST = $(man_MANS) -- but these solutions are ugly in case that there
+# is a lot of "if <cond>", because the result in EXTRA_DIST or dist_man_MANS
+# depends on the condition ;-(
+dist-hook:
+ -find -regex "\./[a-z\-]*/[a-z\.\-\_]*\.[1-9]" -exec cp {} $(distdir)/{} \;
+