summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2016-11-17 03:10:00 +0100
committerKarel Zak2016-11-29 10:47:11 +0100
commit0f0972ac6bab5856e26d7def29f80c5ce424efbd (patch)
tree6a1842c36244f611293469578f21828c79e03429 /configure.ac
parentbuild-sys: update package release number during development (diff)
downloadkernel-qcow2-util-linux-0f0972ac6bab5856e26d7def29f80c5ce424efbd.tar.gz
kernel-qcow2-util-linux-0f0972ac6bab5856e26d7def29f80c5ce424efbd.tar.xz
kernel-qcow2-util-linux-0f0972ac6bab5856e26d7def29f80c5ce424efbd.zip
build-sys: cosmetics PACKAGE_VERSION_MINOR
This should changes nothing. Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eb479cbac..7f4f79e15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,8 +21,8 @@ AC_PREFIX_DEFAULT([/usr])
dnl version details from <major>.<minor>[-<suffix>]
PACKAGE_VERSION_MAJOR=$(echo $PACKAGE_VERSION | awk -F. '{print $1}')
-PACKAGE_VERSION_MINOR=$(echo $PACKAGE_VERSION | awk -F. '{print $2}' \
- | awk -F- '{print $1}')
+PACKAGE_VERSION_MINOR=$(echo $PACKAGE_VERSION | awk -F. '{
+ sub("-.*","",$2); print $2}')
PACKAGE_VERSION_RELEASE=$(echo $PACKAGE_VERSION | awk -F. '{
sub("-.*","",$3); print $3 ~ /^@<:@[0-9]@:>@+$/ ? $3 : 0}')