summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRuediger Meier2016-11-17 03:09:59 +0100
committerKarel Zak2016-11-29 10:47:11 +0100
commitb5511797f2421d8600ed3761b964a1ab7f7629cc (patch)
treeed9c048b1eb3bbd45f6e72771d63a772a964cf96 /configure.ac
parentbuild-sys: fix empty package release number (diff)
downloadkernel-qcow2-util-linux-b5511797f2421d8600ed3761b964a1ab7f7629cc.tar.gz
kernel-qcow2-util-linux-b5511797f2421d8600ed3761b964a1ab7f7629cc.tar.xz
kernel-qcow2-util-linux-b5511797f2421d8600ed3761b964a1ab7f7629cc.zip
build-sys: update package release number during development
Now we use v2.29-5-g8ffab30 -> 2.29.5-8ffa (libblkid 2.29.5) instead of v2.29-5-g8ffab30 -> 2.29.5-8ffa (libblkid 2.29.0) otherwise the bugfix releases (2.29.1) would look newer that latest HEAD. Signed-off-by: Ruediger Meier <ruediger.meier@ga-group.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8391c00c7..eb479cbac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ PACKAGE_VERSION_MAJOR=$(echo $PACKAGE_VERSION | awk -F. '{print $1}')
PACKAGE_VERSION_MINOR=$(echo $PACKAGE_VERSION | awk -F. '{print $2}' \
| awk -F- '{print $1}')
PACKAGE_VERSION_RELEASE=$(echo $PACKAGE_VERSION | awk -F. '{
- print $3 ~ /^@<:@[0-9]@:>@+$/ ? $3 : 0}')
+ sub("-.*","",$3); print $3 ~ /^@<:@[0-9]@:>@+$/ ? $3 : 0}')
dnl libblkid version
LIBBLKID_VERSION="$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_RELEASE"