summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 15:57:18 +0200
committerKarel Zak2011-11-03 12:32:50 +0100
commit0fc74be1ab153936bbfdc41478df3daa2be45210 (patch)
tree61b915ba20bf04d37ee0ca6347a059261b796522 /configure.ac
parentbuild-sys: cleanup BUILD_ARCH (diff)
downloadkernel-qcow2-util-linux-0fc74be1ab153936bbfdc41478df3daa2be45210.tar.gz
kernel-qcow2-util-linux-0fc74be1ab153936bbfdc41478df3daa2be45210.tar.xz
kernel-qcow2-util-linux-0fc74be1ab153936bbfdc41478df3daa2be45210.zip
build-sys: cleanup BUILD_{DDATE,AGETTY}
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1e45f5e2d..205b76c55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -772,13 +772,17 @@ AC_ARG_ENABLE([ddate],
AS_HELP_STRING([--enable-ddate], [do build ddate]),
[], enable_ddate=no
)
-AM_CONDITIONAL(BUILD_DDATE, test "x$enable_ddate" = xyes)
+build_ddate=$enable_ddate
+AM_CONDITIONAL(BUILD_DDATE, test "x$build_ddate" = xyes)
+
AC_ARG_ENABLE([agetty],
AS_HELP_STRING([--disable-agetty], [do not build agetty]),
[], enable_agetty=yes
)
-AM_CONDITIONAL(BUILD_AGETTY, test "x$enable_agetty" = xyes)
+build_agetty=$enable_agetty
+AM_CONDITIONAL(BUILD_AGETTY, test "x$build_agetty" = xyes)
+
AC_ARG_ENABLE([cramfs],
AS_HELP_STRING([--disable-cramfs], [do not build fsck.cramfs, mkfs.cramfs]),