summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStepan Kasal2007-05-15 20:46:05 +0200
committerKarel Zak2007-05-16 11:43:29 +0200
commit1f10890f51a68e3c5d42a02eba80ecb0ec49d20f (patch)
treef937fb396a18d7d9303703907775eb0b9bf481ed /configure.ac
parentbuild-sys: fix the example configure call in README (diff)
downloadkernel-qcow2-util-linux-1f10890f51a68e3c5d42a02eba80ecb0ec49d20f.tar.gz
kernel-qcow2-util-linux-1f10890f51a68e3c5d42a02eba80ecb0ec49d20f.tar.xz
kernel-qcow2-util-linux-1f10890f51a68e3c5d42a02eba80ecb0ec49d20f.zip
build-sys: declare SUID_CFLAGS and SUID_LDFLAGS as precious
Use AC_ARG_VAR to declare the variables SUID_CFLAGS and SUID_LDFLAGS as precious. Signed-off-by: Stepan Kasal <skasal@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8740086df..5564475b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,8 +399,10 @@ if test x$enable_use_tty_group = xyes; then
fi
-AC_SUBST([SUID_CFLAGS])
-AC_SUBST([SUID_LDFLAGS])
+AC_ARG_VAR([SUID_CFLAGS],
+ [CFLAGS used for binaries which are usually with the suid bit])
+AC_ARG_VAR([SUID_LDFLAGS],
+ [LDFLAGS used for binaries which are usually with the suid bit])
LIBS=""