summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-05-21 13:20:10 +0200
committerKarel Zak2009-05-21 13:20:10 +0200
commit28d39b6dd71e6a054aa06c66f683a1e15439e56b (patch)
tree0d5255a5702f2ece589027464f77204d88b66eed /configure.ac
parentfdisk: add simple test for doslabel stuff (diff)
downloadkernel-qcow2-util-linux-28d39b6dd71e6a054aa06c66f683a1e15439e56b.tar.gz
kernel-qcow2-util-linux-28d39b6dd71e6a054aa06c66f683a1e15439e56b.tar.xz
kernel-qcow2-util-linux-28d39b6dd71e6a054aa06c66f683a1e15439e56b.zip
mount: fix undefined reference to `security_get_initial_context'
> Gentoo-hardened stable have: sys-libs/libselinux-1.34.14 > I have: > mount.c:(.text+0x12ce): undefined reference to `security_get_initial_context' Reported-by: Максим Бритов <maxim.britov@gmail.com> Addresses-Gentoo-Bug: #270168 Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af946a15f..b174bce2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,6 +656,11 @@ fi
if test "x$have_selinux" = xyes; then
SELINUX_LIBS="-lselinux -lsepol"
SELINUX_LIBS_STATIC="-lselinux -lsepol"
+ old_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $SELINUX_LIBS"
+ # This function is missing in old libselinux 1.xx versions
+ AC_CHECK_FUNCS([security_get_initial_context])
+ LDFLAGS="$old_LDFLAGS"
fi
AC_SUBST([SELINUX_LIBS])
AC_SUBST([SELINUX_LIBS_STATIC])