summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af946a15f..b174bce2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,6 +656,11 @@ fi
if test "x$have_selinux" = xyes; then
SELINUX_LIBS="-lselinux -lsepol"
SELINUX_LIBS_STATIC="-lselinux -lsepol"
+ old_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS $SELINUX_LIBS"
+ # This function is missing in old libselinux 1.xx versions
+ AC_CHECK_FUNCS([security_get_initial_context])
+ LDFLAGS="$old_LDFLAGS"
fi
AC_SUBST([SELINUX_LIBS])
AC_SUBST([SELINUX_LIBS_STATIC])