summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault2007-11-04 16:54:27 +0100
committerKarel Zak2007-11-08 02:26:36 +0100
commit3bbc9320791e2768eb0ddda3823cb55ad63f79e1 (patch)
treea1de51c23dc935a2deb760d167434b7864eec784 /configure.ac
parentmore: non-linux support (diff)
downloadkernel-qcow2-util-linux-3bbc9320791e2768eb0ddda3823cb55ad63f79e1.tar.gz
kernel-qcow2-util-linux-3bbc9320791e2768eb0ddda3823cb55ad63f79e1.tar.xz
kernel-qcow2-util-linux-3bbc9320791e2768eb0ddda3823cb55ad63f79e1.zip
build-sys: non-linux support
Here is a patch that disables linux-specific tools on non-linux targets. Signed-Off-By: Samuel Thibault <samuel.thibault@ens-lyon.org> Signed-Off-By: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ea72c6b9..dacc79625 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,14 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
[AC_MSG_NOTICE([Your libc thinks that swapon has 1 arg only.])
])
+case ${host_os} in
+ *linux*)
+ AM_CONDITIONAL([LINUX], [true])
+ ;;
+ *)
+ AM_CONDITIONAL([LINUX], [false])
+ ;;
+esac
dnl UTIL_SET_ARCH(ARCHNAME, PATTERN)
dnl ---------------------------------