summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ea72c6b9..dacc79625 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,14 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
[AC_MSG_NOTICE([Your libc thinks that swapon has 1 arg only.])
])
+case ${host_os} in
+ *linux*)
+ AM_CONDITIONAL([LINUX], [true])
+ ;;
+ *)
+ AM_CONDITIONAL([LINUX], [false])
+ ;;
+esac
dnl UTIL_SET_ARCH(ARCHNAME, PATTERN)
dnl ---------------------------------