summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2015-03-26 11:50:15 +0100
committerKarel Zak2015-03-26 11:50:15 +0100
commit43cc76e2631f3b0255bb4817d59d98746f1c309b (patch)
treea01f2a851d136587da91886846f1eb5e4c8b5626 /configure.ac
parenttests: add --exclude=<list> for run.sh (diff)
downloadkernel-qcow2-util-linux-43cc76e2631f3b0255bb4817d59d98746f1c309b.tar.gz
kernel-qcow2-util-linux-43cc76e2631f3b0255bb4817d59d98746f1c309b.tar.xz
kernel-qcow2-util-linux-43cc76e2631f3b0255bb4817d59d98746f1c309b.zip
build-sys: ncurses is optional, don't fail when missing
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f4a015ebc..29ec86d76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,9 +755,10 @@ AS_IF([test "x$with_ncurses" != xno], [
])
])
- AS_IF([test "x$have_ncurses" = xno], [
- AC_MSG_ERROR([ncurses or ncursesw selected, but library not found (--without-ncurses to disable)])
- ])
+ AS_CASE([$with_ncurses:$have_ncurses],
+ [yes:no], [AC_MSG_ERROR([ncurses or ncursesw selected, but library not found])]
+ )
+
])
AC_SUBST([NCURSES_CFLAGS])
AC_SUBST([NCURSES_LIBS])