summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f4a015ebc..29ec86d76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,9 +755,10 @@ AS_IF([test "x$with_ncurses" != xno], [
])
])
- AS_IF([test "x$have_ncurses" = xno], [
- AC_MSG_ERROR([ncurses or ncursesw selected, but library not found (--without-ncurses to disable)])
- ])
+ AS_CASE([$with_ncurses:$have_ncurses],
+ [yes:no], [AC_MSG_ERROR([ncurses or ncursesw selected, but library not found])]
+ )
+
])
AC_SUBST([NCURSES_CFLAGS])
AC_SUBST([NCURSES_LIBS])