summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArkadiusz Miskiewicz2007-06-19 20:58:04 +0200
committerKarel Zak2007-07-02 16:26:20 +0200
commit46e711180f6c7ef6b52373438a4bf0cecb7c646c (patch)
treec3395a25031fde6f0a4ee1bbf6fe14858fde58ca /configure.ac
parentwall: fix O_NONBLOCK usage (diff)
downloadkernel-qcow2-util-linux-46e711180f6c7ef6b52373438a4bf0cecb7c646c.tar.gz
kernel-qcow2-util-linux-46e711180f6c7ef6b52373438a4bf0cecb7c646c.tar.xz
kernel-qcow2-util-linux-46e711180f6c7ef6b52373438a4bf0cecb7c646c.zip
build-sys: fix linking when ncurses is built with --with-termlib=tinfo
When system ncurses is built with --with-termlib=tinfo option then there are two libraries - libtinfo (which contains terminal related functions) and libncurses (rest). Correctly link against libtinfo in such case. Signed-off-by: Arkadiusz Miskiewicz <arekm@maven.pl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aeb92b559..71808defc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,10 @@ AC_ARG_WITH([slang],
[], with_slang=no
)
+have_tinfo=no
+AC_CHECK_LIB(tinfo, tgetent, [have_tinfo=yes])
+AM_CONDITIONAL(HAVE_TINFO, test x$have_tinfo = xyes)
+
use_slang=no
if test x$with_slang = xyes; then
AC_CHECK_HEADERS([slcurses.h slang/slcurses.h], [use_slang=yes])