summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aeb92b559..71808defc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,10 @@ AC_ARG_WITH([slang],
[], with_slang=no
)
+have_tinfo=no
+AC_CHECK_LIB(tinfo, tgetent, [have_tinfo=yes])
+AM_CONDITIONAL(HAVE_TINFO, test x$have_tinfo = xyes)
+
use_slang=no
if test x$with_slang = xyes; then
AC_CHECK_HEADERS([slcurses.h slang/slcurses.h], [use_slang=yes])