summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-29 15:24:04 +0200
committerKarel Zak2012-05-29 15:24:04 +0200
commit71681ee5ecd24ac19747dc692f2350a212e448e9 (patch)
treefb399b8c116fd0385d66a4d36d0a52c5b0c5fd02 /configure.ac
parentbuild-sys: add --enable-vipw (diff)
downloadkernel-qcow2-util-linux-71681ee5ecd24ac19747dc692f2350a212e448e9.tar.gz
kernel-qcow2-util-linux-71681ee5ecd24ac19747dc692f2350a212e448e9.tar.xz
kernel-qcow2-util-linux-71681ee5ecd24ac19747dc692f2350a212e448e9.zip
build-sys: move configure login options to one place
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 27 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index b06c5bb1b..74b3ad303 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1044,6 +1044,15 @@ UL_BUILD_INIT([chfn_chsh])
UL_REQUIRES_HAVE([chfn_chsh], [security_pam_misc_h], [PAM header file])
AM_CONDITIONAL(BUILD_CHFN_CHSH, test "x$build_chfn_chsh" = xyes)
+AC_ARG_ENABLE([chsh-only-listed],
+AS_HELP_STRING([--disable-chsh-only-listed], [chsh: allow shells not in /etc/shells]),
+[], enable_chsh_only_listed=yes
+)
+
+if test "x$enable_chsh_only_listed" = xyes; then
+AC_DEFINE(ONLY_LISTED_SHELLS, 1, [Should chsh allow only shells in /etc/shells?])
+fi
+
AC_ARG_ENABLE([login],
AS_HELP_STRING([--disable-login], [do not build login]),
@@ -1053,6 +1062,24 @@ UL_BUILD_INIT([login])
UL_REQUIRES_HAVE([login], [security_pam_misc_h], [PAM header file])
AM_CONDITIONAL(BUILD_LOGIN, test "x$build_login" = xyes)
+AC_ARG_ENABLE([login-chown-vcs],
+ AS_HELP_STRING([--enable-login-chown-vcs], [let login chown /dev/vcsN]),
+ [], enable_login_chown_vcs=no
+)
+
+if test "x$enable_login_chown_vcs" = xyes; then
+ AC_DEFINE(LOGIN_CHOWN_VCS, 1, [Should login chown /dev/vcsN?])
+fi
+
+AC_ARG_ENABLE([login-stat-mail],
+ AS_HELP_STRING([--enable-login-stat-mail], [let login stat() the mailbox]),
+ [], enable_login_stat_mail=no
+)
+
+if test "x$enable_login_stat_mail" = xyes; then
+ AC_DEFINE(LOGIN_STAT_MAIL, 1, [Should login stat() the mailbox?])
+fi
+
AC_ARG_ENABLE([sulogin],
AS_HELP_STRING([--disable-sulogin], [do not build sulogin]),
@@ -1143,26 +1170,6 @@ if test "x$build_chkdupexe" = xyes; then
fi
-AC_ARG_ENABLE([chsh-only-listed],
- AS_HELP_STRING([--disable-chsh-only-listed], [chsh: allow shells not in /etc/shells]),
- [], enable_chsh_only_listed=yes
-)
-
-if test "x$enable_chsh_only_listed" = xyes; then
- AC_DEFINE(ONLY_LISTED_SHELLS, 1, [Should chsh allow only shells in /etc/shells?])
-fi
-
-
-AC_ARG_ENABLE([login-chown-vcs],
- AS_HELP_STRING([--enable-login-chown-vcs], [let login chown /dev/vcsN]),
- [], enable_login_chown_vcs=no
-)
-
-if test "x$enable_login_chown_vcs" = xyes; then
- AC_DEFINE(LOGIN_CHOWN_VCS, 1, [Should login chown /dev/vcsN?])
-fi
-
-
AC_ARG_ENABLE([socket-activation],
AS_HELP_STRING([--enable-socket-activation], [build uuidd with support for systemd socket activation]),
[], enable_socket_activation=no
@@ -1185,16 +1192,6 @@ fi
AM_CONDITIONAL(WITH_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != "xno" ])
-AC_ARG_ENABLE([login-stat-mail],
- AS_HELP_STRING([--enable-login-stat-mail], [let login stat() the mailbox]),
- [], enable_login_stat_mail=no
-)
-
-if test "x$enable_login_stat_mail" = xyes; then
- AC_DEFINE(LOGIN_STAT_MAIL, 1, [Should login stat() the mailbox?])
-fi
-
-
AC_ARG_ENABLE([pg-bell],
AS_HELP_STRING([--disable-pg-bell], [let pg not ring the bell on invalid keys]),
[], enable_pg_bell=yes