summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-09-26 12:55:30 +0200
committerKarel Zak2013-09-26 12:55:30 +0200
commit808c876512187d146b3d54e1ee2b74a6520b5216 (patch)
tree5a66f988220a9bec3bdd35dbcd2510b37a2f9d81 /configure.ac
parentdocs: update AUTHORS file (diff)
downloadkernel-qcow2-util-linux-808c876512187d146b3d54e1ee2b74a6520b5216.tar.gz
kernel-qcow2-util-linux-808c876512187d146b3d54e1ee2b74a6520b5216.tar.xz
kernel-qcow2-util-linux-808c876512187d146b3d54e1ee2b74a6520b5216.zip
build-sys: install to the correct python dirs
It seems we have to call AM_PATH_PYTHON() monster to get pyexec (shared libs) and python (scripts) directories. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 85faa2e07..18664b977 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1392,8 +1392,7 @@ AS_IF([test "x$with_python" != xno], [
])
PKG_CHECK_MODULES(PYTHON,[${modname} >= $pymajor],
[have_python=yes
- PYTHON_VERSION=`$PKG_CONFIG --modversion $modname`
- AC_SUBST([PYTHON_VERSION])],
+ AM_PATH_PYTHON([$pymajor])],
[have_python=no])
AS_CASE([$with_python:$have_python],
[yes:no],