summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Oprala2013-08-06 18:19:37 +0200
committerKarel Zak2013-08-12 12:07:52 +0200
commitce60272039ea11952b15fefb653892dd0da02217 (patch)
treea44eea1fc9ac4aeb65f001b092cde5de5a25a785 /configure.ac
parentagetty: -L accepts optional argument (diff)
downloadkernel-qcow2-util-linux-ce60272039ea11952b15fefb653892dd0da02217.tar.gz
kernel-qcow2-util-linux-ce60272039ea11952b15fefb653892dd0da02217.tar.xz
kernel-qcow2-util-linux-ce60272039ea11952b15fefb653892dd0da02217.zip
last: merge sysvinit last/lastb
Signed-off-by: Ondrej Oprala <ooprala@redhat.com> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7252e9b35..d0c54247f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -668,7 +668,6 @@ AC_ARG_ENABLE([most-builds],
AS_IF([test "x$enable_most_builds" = xyes], [
enable_chfn_chsh=yes
enable_elvtune=check
- enable_last=yes
enable_line=yes
enable_mesg=yes
enable_newgrp=yes
@@ -1062,9 +1061,18 @@ UL_REQUIRES_LINUX([kill])
AM_CONDITIONAL([BUILD_KILL], [test "x$build_kill" = xyes])
+AC_ARG_ENABLE([deprecated-last],
+ AS_HELP_STRING([--enable-deprecated-last], [build old deprecated last]),
+ [], [enable_deprecated_last=no]
+)
+UL_BUILD_INIT([deprecated_last])
+UL_CONFLICTS_BUILD([last], [deprecated_last], [old deprecated last version])
+AM_CONDITIONAL([BUILD_DEPRECATED_LAST], [test "x$build_deprecated_last" = xyes])
+
+
AC_ARG_ENABLE([last],
- AS_HELP_STRING([--enable-last], [build last]),
- [], [enable_last=no]
+ AS_HELP_STRING([--disable-last], [do not build last]),
+ [], [enable_last=yes]
)
UL_BUILD_INIT([last])
AM_CONDITIONAL([BUILD_LAST], [test "x$build_last" = xyes])