summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2011-10-27 16:02:29 +0200
committerKarel Zak2011-11-03 12:32:50 +0100
commitd81b5a5217395850df7c5d49890f2177710449db (patch)
tree01b76a10010547bcb0b7062fa579a52c15d48ba5 /configure.ac
parentbuild-sys: cleanup BUILD_{DDATE,AGETTY} (diff)
downloadkernel-qcow2-util-linux-d81b5a5217395850df7c5d49890f2177710449db.tar.gz
kernel-qcow2-util-linux-d81b5a5217395850df7c5d49890f2177710449db.tar.xz
kernel-qcow2-util-linux-d81b5a5217395850df7c5d49890f2177710449db.zip
build-sys: cleanup BUILD_CRAMFS
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 205b76c55..0afa7b1ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -788,17 +788,9 @@ AC_ARG_ENABLE([cramfs],
AS_HELP_STRING([--disable-cramfs], [do not build fsck.cramfs, mkfs.cramfs]),
[], enable_cramfs=check
)
-
-if test "x$enable_cramfs" = xno; then
- build_cramfs=no
-else
- build_cramfs=yes
- dnl Trick: leave the third parameter empty to get the default action.
- AC_CHECK_LIB(z, crc32, [], build_cramfs=no)
- case $enable_cramfs:$build_cramfs in
- yes:no) AC_MSG_ERROR([cramfs selected but libz not found]);;
- esac
-fi
+build_cramfs=yes
+AC_CHECK_LIB(z, crc32, [have_z=yes], [have_z=no])
+UL_REQUIRES_HAVE([cramfs], [z], [z library])
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)