summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni2012-06-02 09:41:51 +0200
committerPeter Korsgaard2012-06-05 00:20:31 +0200
commit74da2cca30852cc12c5f6e83be39e301aff74d62 (patch)
tree2796bdbaac368054ecca37b66364523d6d7bf30d
parentquagga: fix non-IPv6 build failures (diff)
downloadbuildroot-74da2cca30852cc12c5f6e83be39e301aff74d62.tar.gz
buildroot-74da2cca30852cc12c5f6e83be39e301aff74d62.tar.xz
buildroot-74da2cca30852cc12c5f6e83be39e301aff74d62.zip
beecrypt: fix build failure of C++ code with g++ 4.7
This fixes http://autobuild.buildroot.org/results/5c1e904b201676275465c902ba3c09951973755c/build-end.log. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/beecrypt/beecrypt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index a0187cee6..7642c1b8e 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -7,6 +7,13 @@ BEECRYPT_VERSION = 4.2.1
BEECRYPT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/beecrypt
BEECRYPT_AUTORECONF = YES
BEECRYPT_INSTALL_STAGING = YES
+
+# beecrypt contains C++ code that g++ 4.7 doesn't really
+# like. Upstream does not seem to be really active, so workaround this
+# by passing -fpermissive.
+BEECRYPT_CONF_ENV = \
+ CXXFLAGS="$(TARGET_CXXFLAGS) -fpermissive"
+
BEECRYPT_CONF_OPT = \
--without-java \
--without-python