summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/beecrypt/beecrypt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index a0187cee6..7642c1b8e 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -7,6 +7,13 @@ BEECRYPT_VERSION = 4.2.1
BEECRYPT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/beecrypt
BEECRYPT_AUTORECONF = YES
BEECRYPT_INSTALL_STAGING = YES
+
+# beecrypt contains C++ code that g++ 4.7 doesn't really
+# like. Upstream does not seem to be really active, so workaround this
+# by passing -fpermissive.
+BEECRYPT_CONF_ENV = \
+ CXXFLAGS="$(TARGET_CXXFLAGS) -fpermissive"
+
BEECRYPT_CONF_OPT = \
--without-java \
--without-python