summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard2012-06-11 22:42:29 +0200
committerPeter Korsgaard2012-06-11 22:42:29 +0200
commit83f43bab374535fe39d93547fb03c52fa45ab0a8 (patch)
tree885f61a2f91d306401dbc0bb20342d5713054353
parentpciutils: install headers and libraries in STAGING_DIR (diff)
downloadbuildroot-83f43bab374535fe39d93547fb03c52fa45ab0a8.tar.gz
buildroot-83f43bab374535fe39d93547fb03c52fa45ab0a8.tar.xz
buildroot-83f43bab374535fe39d93547fb03c52fa45ab0a8.zip
pciutils: simplify
No need for two seperate make invocations for installation. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/pciutils/pciutils.mk8
1 files changed, 2 insertions, 6 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 7de5fd7b4..d1c8db509 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -46,16 +46,12 @@ endef
# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install-lib
+ SHARED=$(PCIUTILS_SHARED) install install-lib
endef
define PCIUTILS_INSTALL_STAGING_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install-lib
+ SHARED=$(PCIUTILS_SHARED) install install-lib
endef
$(eval $(call GENTARGETS))