summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/pciutils/pciutils.mk8
1 files changed, 2 insertions, 6 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 7de5fd7b4..d1c8db509 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -46,16 +46,12 @@ endef
# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install-lib
+ SHARED=$(PCIUTILS_SHARED) install install-lib
endef
define PCIUTILS_INSTALL_STAGING_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install
- $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(STAGING_DIR)/usr \
- SHARED=$(PCIUTILS_SHARED) install-lib
+ SHARED=$(PCIUTILS_SHARED) install install-lib
endef
$(eval $(call GENTARGETS))