summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Pasch2010-12-08 23:09:03 +0100
committerPeter Korsgaard2010-12-08 23:09:24 +0100
commitd3d67f7fb527b3b549d9da0c67b42477a224b00b (patch)
tree43762e9cfe798d68d65f1fc238e138bddaff6d82
parentccache: rework ccache management (diff)
downloadbuildroot-d3d67f7fb527b3b549d9da0c67b42477a224b00b.tar.gz
buildroot-d3d67f7fb527b3b549d9da0c67b42477a224b00b.tar.xz
buildroot-d3d67f7fb527b3b549d9da0c67b42477a224b00b.zip
qt: only build gui module if enabled
Closes #2905 Signed-off-by: Frederik Pasch <fpasch@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES6
-rw-r--r--package/qt/qt.mk4
2 files changed, 9 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index f08353d01..45585c182 100644
--- a/CHANGES
+++ b/CHANGES
@@ -3,10 +3,14 @@
Ccache support reworked. Now used for both host and target
compilation, and cache is stored in ~/.buildroot-ccache.
- Updated/fixed packages: cloop, m4, openssh, xz
+ Updated/fixed packages: cloop, m4, openssh, qt, xz
New packages: lsuio
+ Issues resolved (http://bugs.uclibc.org):
+
+ #2905: Qt: Speed up compilation, if gui-module isn't selected
+
2010.11, Released November 30th, 2010:
Fixes all over the tree.
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index e344259ae..2b5b31b78 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -190,6 +190,10 @@ else
QT_CONFIGURE+= -big-endian
endif
+ifneq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
+QT_CONFIGURE+= -no-gui
+endif
+
ifeq ($(BR2_PACKAGE_QT_GIF),y)
QT_CONFIGURE+= -qt-gif
else