summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--package/qt/qt.mk4
2 files changed, 9 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index f08353d01..45585c182 100644
--- a/CHANGES
+++ b/CHANGES
@@ -3,10 +3,14 @@
Ccache support reworked. Now used for both host and target
compilation, and cache is stored in ~/.buildroot-ccache.
- Updated/fixed packages: cloop, m4, openssh, xz
+ Updated/fixed packages: cloop, m4, openssh, qt, xz
New packages: lsuio
+ Issues resolved (http://bugs.uclibc.org):
+
+ #2905: Qt: Speed up compilation, if gui-module isn't selected
+
2010.11, Released November 30th, 2010:
Fixes all over the tree.
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index e344259ae..2b5b31b78 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -190,6 +190,10 @@ else
QT_CONFIGURE+= -big-endian
endif
+ifneq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
+QT_CONFIGURE+= -no-gui
+endif
+
ifeq ($(BR2_PACKAGE_QT_GIF),y)
QT_CONFIGURE+= -qt-gif
else