summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohann Latocha2012-06-27 18:02:29 +0200
committerJohann Latocha2012-06-27 18:02:29 +0200
commitd5835bd1dc3847a212f08ebbde13014643ef2b81 (patch)
treeaec2f75fbed1f49a82101f2e2675e3f6be7f114d
parentminor systemd fixes (diff)
downloadbuildroot-d5835bd1dc3847a212f08ebbde13014643ef2b81.tar.gz
buildroot-d5835bd1dc3847a212f08ebbde13014643ef2b81.tar.xz
buildroot-d5835bd1dc3847a212f08ebbde13014643ef2b81.zip
add plymouth
-rw-r--r--package/Config.in1
-rw-r--r--package/plymouth/Config.in12
-rw-r--r--package/plymouth/plymouth.mk20
3 files changed, 33 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 1044e9fa2..52f04ee7c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -103,6 +103,7 @@ menu "Graphic libraries and applications (graphic/text)"
comment "Graphic applications"
source "package/rrdtool/Config.in"
+source "package/plymouth/Config.in"
comment "graphic libraries"
source "package/directfb/Config.in"
diff --git a/package/plymouth/Config.in b/package/plymouth/Config.in
new file mode 100644
index 000000000..94fd9d8db
--- /dev/null
+++ b/package/plymouth/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PLYMOUTH
+ bool "plymouth"
+ default n
+ select BR2_PACKAGE_PKG_CONFIG
+ select BR2_PACKAGE_PANGO
+ select BR2_PACKAGE_LIBGTK2
+ help
+ Plymouth is a bootsplash for Linux. It supports animations.
+ It makes use of Direct Rendering Manager (DRM) and kernel-based mode-setting (KMS).
+ It gets packed into the initrd.
+
+ http://www.freedesktop.org/wiki/Software/Plymouth
diff --git a/package/plymouth/plymouth.mk b/package/plymouth/plymouth.mk
new file mode 100644
index 000000000..6ff7f5664
--- /dev/null
+++ b/package/plymouth/plymouth.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# plymouth
+#
+#############################################################
+
+PLYMOUTH_VERSION = 0.8.5
+PLYMOUTH_SITE = http://www.freedesktop.org/software/plymouth/releases
+PLYMOUTH_SOURCE = plymouth-$(PLYMOUTH_VERSION).tar.bz2
+
+
+define PLYMOUTH_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/src/plymouth $(TARGET_DIR)/bin/plymouth
+endef
+
+define PLYMOUTH_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/bin/plymouth
+endef
+
+$(eval $(call AUTOTARGETS))